Instant first new post failed install problem

  • No Bug
  • Instant first new post failed install problem

    Can't install the pacakge becouse of issue:



    The patch that this package is trying to apply has failed because this patch is not compliant to its target file. Therefore this package cannot be installed. Please click the "Cancel the installation" button.
    error message: Can't find an appropriate location for applying this hunk.
    error code: 20015
    affected template: /srv/btlcmd/pony/wcf/../templates/boardRecentActivityBox.tpl


    Also can't install optional package of portalbox of last threads with the same error.
    Initial package can be installed, but don't work properly somehow:even arrows not appear. But everyting worked well earlier.


    WBB version: 3.1.8
    WCFversion: 1.1.10 pl 2

    PHP Version: 5.5.24


    P.S. Sorry for my bad english.
  • You have to look into your ACP in the table wcfX_template_patch (where X is the installation number of Community Framework). There you can find the patch, which patches the specified template. Then you can look which packageID this template patch is assigned to and can look into your package list which package this packageID has.
    Viele Grüße
    Best Regards

    Matthias Kittsteiner
  • The proble with recent activity box is solved (there was a junk)
    But now the same problem in inother optional package with the same error in affected template: lastthreads.tpl

    Now everything is clear: no junks, patches, even file is equal to original from portal 2.2.3. But error persists.
  • Well... I don't really know what's was going wromg. Anyway one good friend already helped to solve the update problem with changing of DIFF-file of the package (atteched to reply). That was a problem in... as he say "different endings"

    With this file, the package installed without errors.

    But there's still a question: the arrows to first unread aren't apeared in last threads portal box and the index forum board. The arrows in thredlist of categiry appeared.
    As far as I remember, they must appear in these places.
    Something went wrong?
    Files
    • template.zip

      (548 Byte, downloaded 77 times, last: )
  • Sorry, my fault. There was a "general -> board" option: "Show last post of the forum" what was disabled. Arrows on the board works now.

    The default arrow on "last threads jumps" portalbox to last unread post anyway, the same is on the previos forum. I guess it means "anything working" now :)

    Thanks for your help.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.