Frage zu den Updates deiner Plugins

  • Plugin
  • 3.0.x
  • Frage zu den Updates deiner Plugins

    Hey,

    habe mal eine Frage zu den Updates deiner Plugins.
    Wenn ich jetzt ein Update auf die Woltlab Suite 3.1. mache und von dir Plugins drin habe, aktualisiere ich sie vor dem großen Update oder muss ich sie erst deinstallieren und wenn das Update fertig ist, dann neu installieren?
    Weil einen Paketserver hast du ja nicht, oder?

    Liebe Grüße,
    Zero :)
  • Wir arbeiten bereits mit Hochdruck an einem eigenen Paketserver, aber ja, aktuell können wir diesen leider noch nicht anbieten, da es noch zwei kleinere Fehler gibt.

    Es gibt drei Möglichkeiten, die du aktuell hast:
    1. Unsere Plugins vor dem Update deinstallieren.
    2. Warten, bis der Paketserver soweit ist.
    3. Eine Abfrage ausführen, um die Limitierung auf WoltLab Suite Core 3.0 temporär zu entfernen.
    Letzteres ginge mit folgenden Abfragen:

    SQL-Abfrage

    1. UPDATE wcf1_package_exclusion
    2. SET excludedPackageVersion = '3.2.0 Alpha 1'
    3. WHERE packageID = (
    4. SELECT packageID
    5. FROM wcf1_package
    6. WHERE package = 'com.kittmedia.wcf.crystaltemptation'
    7. );
    8. UPDATE wcf1_package_exclusion
    9. SET excludedPackageVersion = '3.2.0 Alpha 1'
    10. WHERE packageID = (
    11. SELECT packageID
    12. FROM wcf1_package
    13. WHERE package = 'com.kittmedia.wcf.dreamily'
    14. );
    15. UPDATE wcf1_package_exclusion
    16. SET excludedPackageVersion = '3.2.0 Alpha 1'
    17. WHERE packageID = (
    18. SELECT packageID
    19. FROM wcf1_package
    20. WHERE package = 'com.kittmedia.wcf.freedomoflife'
    21. );
    22. UPDATE wcf1_package_exclusion
    23. SET excludedPackageVersion = '3.2.0 Alpha 1'
    24. WHERE packageID = (
    25. SELECT packageID
    26. FROM wcf1_package
    27. WHERE package = 'com.kittmedia.wcf.hypidiomorphic'
    28. );
    29. UPDATE wcf1_package_exclusion
    30. SET excludedPackageVersion = '3.2.0 Alpha 1'
    31. WHERE packageID = (
    32. SELECT packageID
    33. FROM wcf1_package
    34. WHERE package = 'com.kittmedia.wcf.thedepthofblue'
    35. );
    36. UPDATE wcf1_package_exclusion
    37. SET excludedPackageVersion = '3.2.0 Alpha 1'
    38. WHERE packageID = (
    39. SELECT packageID
    40. FROM wcf1_package
    41. WHERE package = 'com.kittmedia.wcf.aboutus'
    42. );
    43. UPDATE wcf1_package_exclusion
    44. SET excludedPackageVersion = '3.2.0 Alpha 1'
    45. WHERE packageID = (
    46. SELECT packageID
    47. FROM wcf1_package
    48. WHERE package = 'com.kittmedia.wcf.faq'
    49. );
    50. UPDATE wcf1_package_exclusion
    51. SET excludedPackageVersion = '3.2.0 Alpha 1'
    52. WHERE packageID = (
    53. SELECT packageID
    54. FROM wcf1_package
    55. WHERE package = 'com.kittmedia.wcf.headerimagechanger'
    56. );
    57. UPDATE wcf1_package_exclusion
    58. SET excludedPackageVersion = '3.2.0 Alpha 1'
    59. WHERE packageID = (
    60. SELECT packageID
    61. FROM wcf1_package
    62. WHERE package = 'com.kittmedia.wcf.mobilesettings'
    63. );
    64. UPDATE wcf1_package_exclusion
    65. SET excludedPackageVersion = '3.2.0 Alpha 1'
    66. WHERE packageID = (
    67. SELECT packageID
    68. FROM wcf1_package
    69. WHERE package = 'com.kittmedia.wcf.mobilestylechanger'
    70. );
    71. UPDATE wcf1_package_exclusion
    72. SET excludedPackageVersion = '3.2.0 Alpha 1'
    73. WHERE packageID = (
    74. SELECT packageID
    75. FROM wcf1_package
    76. WHERE package = 'com.kittmedia.wcf.partners'
    77. );
    78. UPDATE wcf1_package_exclusion
    79. SET excludedPackageVersion = '3.2.0 Alpha 1'
    80. WHERE packageID = (
    81. SELECT packageID
    82. FROM wcf1_package
    83. WHERE package = 'com.kittmedia.wcf.teaserbox'
    84. );
    85. UPDATE wcf1_package_exclusion
    86. SET excludedPackageVersion = '3.2.0 Alpha 1'
    87. WHERE packageID = (
    88. SELECT packageID
    89. FROM wcf1_package
    90. WHERE package = 'com.kittmedia.wcf.style.base'
    91. );
    Alles anzeigen
    Danach kannst du das Update durchführen, ohne dass unsere Produkte selbiges aufhalten. Wichtig ist nur, dass du dann aus Kompatibilitätsgründen die Updates unserer Produkte danach dennoch machst.
    Viele Grüße
    Best Regards

    Matthias Kittsteiner
  • Wenn ich dies auch für die Team-Dashboard Box umsetzen möchte, würde der Code dann wie folgt lauten?

    SQL-Abfrage

    1. UPDATE wcf1_package_exclusion
    2. SET excludedPackageVersion = '3.2.0 Alpha 1'
    3. WHERE packageID = (
    4. SELECT packageID
    5. FROM wcf1_package
    6. WHERE package = 'com.kittmedia.wcf.teamdashboardbox'
    7. );
    Allerdings gibt es hier noch kein Update, welches ich anschließend manuell nachinstallieren könnte. Aber versuchen könnte ich es doch trotzdem oder?
  • Theoretisch ja, wir haben uns die Kompatibilität diesbezüglich noch nicht angesehen. Deshalb kann ich nicht mit Sicherheit sagen, dass dort keine Fehler auftreten.

    Hier würde ich dir übergangsweise eher empfehlen, das Plugin zu entfernen. Da es keine umfangreiche Einstellungen besitzt, wäre das die sicherste Methode.
    Viele Grüße
    Best Regards

    Matthias Kittsteiner

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen